Key |
Finds the KeyBasedTreeEntry associated with the given key value.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- key String
- The specified key value.
Return Value
KeyBasedTreeEntryThe KeyBasedTreeEntry corresponds to the given key value.

Exception | Condition |
---|---|
ArgumentException | key is an empty string. |
ArgumentNullException | A non-optional argument was null |

If no matching KeyBasedTreeEntry can be found, null will be returned; The given key value cannot be an empty string.