SetDepthCueing Method


Sets the depth cueing settings for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public void SetDepthCueing(
	ViewDisplayDepthCueing depthCueing
)
Visual Basic
Public Sub SetDepthCueing ( _
	depthCueing As ViewDisplayDepthCueing _
)
Visual C++
public:
void SetDepthCueing(
	ViewDisplayDepthCueing^ depthCueing
)

Parameters

depthCueing
Type: Autodesk.Revit.DBViewDisplayDepthCueing
Depth cueing settings to set.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException This view does not contain display-related properties. -or- This view cannot use Depth Cueing

See Also