A chain of curves representing the centerline of the rebar.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- adjustForSelfIntersection
- Type: SystemBoolean
If the curves overlap, as in a planar stirrup, this parameter controls whether they should be adjusted to avoid intersection (as in fine views), or kept in a single plane for simplicity (as in coarse views).
- suppressHooks
- Type: SystemBoolean
Identifies if the chain will include hooks curves.
- suppressBendRadius
- Type: SystemBoolean
Identifies if the connected chain will include unfilleted curves.
Return Value
The centerline curves or empty array if the curves cannot be computed because the parameters values are inconsistent with the constraints of the RebarShape definition.Remarks
This method will return the centerline curves for the first bar in set even if this bar isn't included.