Rebar |
A chain of curves representing the centerline of the rebar.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public IList<Curve> GetCenterlineCurves(
bool adjustForSelfIntersection,
bool suppressHooks,
bool suppressBendRadius
)
Parameters
- adjustForSelfIntersection Boolean
- If the curves overlap, as in a planar stirrup, this parameter controls whether they should be adjusted to avoid intersection (as in fine views), or kept in a single plane for simplicity (as in coarse views).
- suppressHooks Boolean
- Identifies if the chain will include hooks curves.
- suppressBendRadius Boolean
- Identifies if the connected chain will include unfilleted curves.
Return Value
IList CurveThe centerline curves or empty array if the curves cannot be computed because the parameters values are inconsistent with the constraints of the RebarShape definition.

This method will return the centerline curves for the first bar in set even if this bar isn't included.