DoDragDrop Method (Object, IDropHandler)


Initiates a drag and drop operation with a custom drop implementation.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public static void DoDragDrop(
	Object dropData,
	IDropHandler handler
)
Visual Basic
Public Shared Sub DoDragDrop ( _
	dropData As Object, _
	handler As IDropHandler _
)
Visual C++
public:
static void DoDragDrop(
	Object^ dropData, 
	IDropHandler^ handler
)

Parameters

dropData
Type: SystemObject
Any arbitrary data to be passed to the drop handler when the drop occurs.
handler
Type: Autodesk.Revit.UIIDropHandler
The handler to be executed when the drop occurs.

Remarks

When the user inputs IControllableDropHandler, it allows the handler to verify whether the drop event can be executed on the given view; When the user inputs IDropHandler the handler will be executed without any condition.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullExceptionThrown when dropData or handler is a null reference (Nothing in Visual Basic).

See Also