UIApplication Do |
Initiates a drag and drop operation with a custom drop implementation.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- dropData Object
- Any arbitrary data to be passed to the drop handler when the drop occurs.
- handler IDropHandler
- The handler to be executed when the drop occurs.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when dropData or handler is . |

When the user inputs IControllableDropHandler , it allows the handler to verify whether the drop event can be executed on the given view; When the user inputs IDropHandler the handler will be executed without any condition.