CanBeIntersectionElement Method


Checks if the element can be an intersection reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public bool CanBeIntersectionElement(
	ElementId id
)
Visual Basic
Public Function CanBeIntersectionElement ( _
	id As ElementId _
) As Boolean
Visual C++
public:
bool CanBeIntersectionElement(
	ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DBElementId
The element to be checked.

Return Value

True if the element can be an intersection reference., false otherwise.

Remarks

The element must be a level, grid, reference plane, or a curve element whose category is lines and reference lines.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also