GetAdditionalElementIds Method


Retrieves Ids of Elements that have not caused the failure but are related to it Checks if the failure has resolution of a given resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public ICollection<ElementId> GetAdditionalElementIds()
Visual Basic
Public Function GetAdditionalElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAdditionalElementIds()

Return Value

Ids of Elements related to the failure

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException This FailureMessageAccessor has not been properly initialized.

See Also