PhotometricWebLightDistribution Constructor (String, Double)


Creates a photometric web light distribution object with the given filename and tilt.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public PhotometricWebLightDistribution(
	string photometricWebFile,
	double tiltAngle
)
Visual Basic
Public Sub New ( _
	photometricWebFile As String, _
	tiltAngle As Double _
)
Visual C++
public:
PhotometricWebLightDistribution(
	String^ photometricWebFile, 
	double tiltAngle
)

Parameters

photometricWebFile
Type: SystemString
The filename of the IES file to use.
tiltAngle
Type: SystemDouble
The tilt angle as a numerical value in degrees between -180.0 and 180.0.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The angle is not valid because it is not between -180.0 and 180.0.

See Also