PhotometricWebLightDistribution Constructor (String, Double)


Photometric Web Light Distribution(String, Double) Constructor

Creates a photometric web light distribution object with the given filename and tilt.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public PhotometricWebLightDistribution(
	string photometricWebFile,
	double tiltAngle
)

Parameters

photometricWebFile String
The filename of the IES file to use.
tiltAngle Double
The tilt angle as a numerical value in degrees between -180.0 and 180.0.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The angle is not valid because it is not between -180.0 and 180.0.
See Also