RemoveUnfilterableCategories Method


Removes from the given set the categories that are not filterable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static ICollection<ElementId> RemoveUnfilterableCategories(
	ICollection<ElementId> categories
)
Visual Basic
Public Shared Function RemoveUnfilterableCategories ( _
	categories As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ RemoveUnfilterableCategories(
	ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.GenericICollectionElementId
The set of categories to check.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also