SetAutoCalcHookLengths Method


Identifies if the hook lengths of a hook type are automatically calculated for this bar type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetAutoCalcHookLengths(
	ElementId hookId,
	bool autoCalculated
)
Visual Basic
Public Sub SetAutoCalcHookLengths ( _
	hookId As ElementId, _
	autoCalculated As Boolean _
)
Visual C++
public:
void SetAutoCalcHookLengths(
	ElementId^ hookId, 
	bool autoCalculated
)

Parameters

hookId
Type: Autodesk.Revit.DBElementId
id of the hook type
autoCalculated
Type: SystemBoolean
True if the hook lengths should be automatically calculated, otherwise false When it is false, default hook length and default hook offset length will be reported

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also