SetAutoCalcHookLengths Method


Rebar Bar Type Set Auto Calc Hook Lengths Method

Identifies if the hook lengths of a hook type are automatically calculated for this bar type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetAutoCalcHookLengths(
	ElementId hookId,
	bool autoCalculated
)

Parameters

hookId ElementId
id of the hook type
autoCalculated Boolean
True if the hook lengths should be automatically calculated, otherwise false When it is false, default hook length and default hook offset length will be reported
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also