This class represents another Revit Document ("link") brought into
the current one ("host").
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
Revit links can be nested - There can exist linked files which themselves contain
links. A "top-level" link is one linked directly into the host, while a
"nested" link is linked into some parent link. This can go through
arbitrarily many layers.
Some functions give the example "A -> B -> C". This means that there is
a host file, A, which has a top-level link, B, and a nested link C which
has been linked into B as an attachment.
Inheritance Hierarchy
System
Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB ElementType
Autodesk.Revit.DB RevitLinkType
Autodesk.Revit.DB Element
Autodesk.Revit.DB ElementType
Autodesk.Revit.DB RevitLinkType