RevitLinkType Class


Revit Link Type Class

This class represents another Revit Document ("link") brought into the current one ("host").
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RevitLinkType : ElementType

The RevitLinkType type exposes the following members.

Properties
Name Description
Public property AssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element )
Public property AttachmentType The attachment/overlay status of this link.
Public property Code example BoundingBox Retrieves a box that circumscribes all geometry of the element.
(Inherited from Element )
Public property CanBeCopied Determine if this ElementType can create a copy
(Inherited from ElementType )
Public property CanBeDeleted Determine if this ElementType can be deleted
(Inherited from ElementType )
Public property CanBeRenamed Determine if this ElementType can be renamed
(Inherited from ElementType )
Public property Category Retrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element )
Public property Code example CreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element )
Public property Code example DemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element )
Public property Code example DesignOption Returns the design option to which the element belongs.
(Inherited from Element )
Public property Document Returns the Document in which the Element resides.
(Inherited from Element )
Public property FamilyName Gets the family name of this element type.
(Inherited from ElementType )
Public property Code example Geometry Retrieves the geometric representation of the element.
(Inherited from Element )
Public property GroupId The id of the group to which an element belongs.
(Inherited from Element )
Public property Code example Id A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element )
Public property IsModifiable Identifies if the element is modifiable.
(Inherited from Element )
Public property IsNestedLink Indicates whether this link is a nested or top-level link.
Public property IsTransient Indicates whether an element is transient or permanent.
(Inherited from Element )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element )
Public property LevelId The id of the level associated with the element.
(Inherited from Element )
Public property LocallyUnloaded Checks whether a Revit link in a local model is unloaded only for the current user.
Public property Code example Location This property is used to find the physical location of an element within a project.
(Inherited from Element )
Public property Name Set the name for the ElementType.
(Inherited from ElementType )
Public property OwnerViewId The id of the view that owns the element.
(Inherited from Element )
Public property Code example Parameter BuiltInParameter Retrieves a parameter from the element given a parameter id.
(Inherited from Element )
Public property Parameter Definition Retrieves a parameter from the element based on its definition.
(Inherited from Element )
Public property Parameter Guid Retrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element )
Public property Code example Parameters Retrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property ParametersMap Retrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property PathType The type of path the link uses.
Public property Pinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element )
Public property Code example UniqueId A stable unique identifier for an element within the document.
(Inherited from Element )
Public property VersionGuid Get the element version Guid.
(Inherited from Element )
Public property ViewSpecific Identifies if the element is owned by a view.
(Inherited from Element )
Public property WorksetId Get Id of the Workset which owns the element.
(Inherited from Element )
Top
Methods
Name Description
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element )
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element )
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element )
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element )
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element )
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element )
Public method Static member Create(Document, ExternalResourceReference, RevitLinkOptions) Creates a new Revit link type from an external resource reference and loads the linked document.
Public method Static member Code example Create(Document, ModelPath, RevitLinkOptions) Creates a new Revit link type and loads the linked document.
Public method Static member CreateFromIFC(Document, ExternalResourceReference, String, Boolean, RevitLinkOptions) Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.
Public method Static member CreateFromIFC(Document, String, String, Boolean, RevitLinkOptions) Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element )
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element )
Public method DeleteSubelements Removes the subelements from the element.
(Inherited from Element )
Public method Dispose
(Inherited from Element )
Public method Duplicate Duplicates an existing element type and assigns it a new name.
(Inherited from ElementType )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element )
Public method EvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element )
Public method GetChildIds Gets the ids of the immediate children of this link.
Public method GetConversionData Returns the optional data that is necessary to generate the Revit file for this link.
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element )
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element )
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element )
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element )
Public method Code example GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element )
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetLinkedFileStatus Returns the LinkedFileStatus of this link.
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element )
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element )
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element )
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element )
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element )
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element )
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element )
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element )
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element )
Public method GetParentId Gets the id of this link's immediate parent.
Public method GetPhaseMap Returns a mapping between phases in the host document and phases in the linked document.
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element )
Public method GetPreviewImage Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
(Inherited from ElementType )
Public method GetRootId Gets the id of the top-level link which this link is linked into.
Public method GetSimilarTypes Obtains a set of types that are similar to this type.
(Inherited from ElementType )
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element )
Public method Static member GetTopLevelLink(Document, ExternalResourceReference) Returns the ElementId of the (top-level) linked model with the given ExternalResourceReference.
Public method Static member GetTopLevelLink(Document, ModelPath) Returns the ElementId of the (top-level) linked model with the given path.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Code example GetTypeId Returns the identifier of this element's type.
(Inherited from Element )
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element )
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element )
Public method HasSaveablePositions Determines whether the link has changes to shared positioning that could be saved.
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element )
Public method IsFromLocalPath Checks whether the Revit link uses a local path, such as a hard drive.
Public method IsFromRevitServer Checks whether the Revit link is located on Revit Server.
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element )
Public method Static member IsLoaded Checks whether the link with this id is loaded.
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element )
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element )
Public method IsNotLoadedIntoMultipleOpenDocuments Checks whether the link is loaded into more than one open document in this session of Revit. If the link is loaded into multiple open documents, reload will be disabled.
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element )
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element )
Public method IsSimilarType Checks if given type is similar to this type.
(Inherited from ElementType )
Public method IsValidDefaultFamilyType Identifies if this type is a valid default family type for the given family category id.
(Inherited from ElementType )
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element )
Public method Load Loads or reloads the Revit link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method LoadFrom(ExternalResourceReference, WorksetConfiguration) Loads or reloads the Revit link. The link will be loaded from the location given in the input ExternalResourceReference.
Public method LoadFrom(ModelPath, WorksetConfiguration) Loads or reloads the Revit link from disk or cloud. The link will be loaded from the input path.
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element )
Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element )
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element )
Public method Reload Loads or reloads the Revit link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method RevertLocalUnloadStatus Restores the workshared load status of a link that has been unloaded only for the current user, in a local copy of a workshared model.
Public method SavePositions Saves shared coordinates changes back to the linked document.
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Public method Unload Unloads the Revit link.
Public method UnloadLocally Unloads a Revit link for the current user only.
Public method UpdateFromIFC(Document, ExternalResourceReference, String, Boolean) Updates a Revit link type from an IFC file and loads the linked document.
Public method UpdateFromIFC(Document, String, String, Boolean) Updates a Revit link type from an IFC file and loads the linked document.
Top
Remarks
Revit links can be nested - There can exist linked files which themselves contain links. A "top-level" link is one linked directly into the host, while a "nested" link is linked into some parent link. This can go through arbitrarily many layers. Some functions give the example "A -> B -> C". This means that there is a host file, A, which has a top-level link, B, and a nested link C which has been linked into B as an attachment.
See Also