Gets the LinePattern associated to an element or from a built-in line pattern.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document in which to retrieve the LinePattern.
- elementId
- Type: Autodesk.Revit.DBElementId
The ElementId of the LinePatternElement or the built-in line pattern id.
Return Value
A copy of LinePattern object. a null reference (Nothing in Visual Basic) if the ElementId doesn't represent a line pattern element or built-in line pattern. a null reference (Nothing in Visual Basic) for Solid.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |