Line |
Gets the LinePattern associated to an element or from a built-in line pattern.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- document Document
- The document in which to retrieve the LinePattern.
- elementId ElementId
- The ElementId of the LinePatternElement or the built-in line pattern id.
Return Value
LinePatternA copy of LinePattern object. if the ElementId doesn't represent a line pattern element or built-in line pattern. for Solid.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |