IsNameUnused Method


Checks if this is an unused name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public static bool IsNameUnused(
	Document doc,
	string name
)
Visual Basic
Public Shared Function IsNameUnused ( _
	doc As Document, _
	name As String _
) As Boolean
Visual C++
public:
static bool IsNameUnused(
	Document^ doc, 
	String^ name
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
The document.
name
Type: SystemString
The name to be verified.

Return Value

True if not used by an existing analytical connection type in this document, false if used.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also