GetAllRebarShapeParameters Method


List all shape parameters used by all the existing RebarShapes in the specified document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static IList<ElementId> GetAllRebarShapeParameters(
	Document doc
)
Visual Basic
Public Shared Function GetAllRebarShapeParameters ( _
	doc As Document _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetAllRebarShapeParameters(
	Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
The document.

Return Value

ElementIds corresponding to the external parameters.

Remarks

This method replaces RebarShape.GetAllRebarShapeParameters() from prior releases.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also