GetAllRebarShapeParameters Method


Rebar Shape Parameters Get All Rebar Shape Parameters Method

List all shape parameters used by all the existing RebarShapes in the specified document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<ElementId> GetAllRebarShapeParameters(
	Document doc
)

Parameters

doc Document
The document.

Return Value

IList ElementId
ElementIds corresponding to the external parameters.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
This method replaces RebarShape.GetAllRebarShapeParameters() from prior releases.
See Also