This indicates whether the input spatial element is a valid one.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- spatialElement
- Type: Autodesk.Revit.DBSpatialElement
The spatial element to be checked if its geometry can be calculated.
Return Value
It will return false if the room/space is not enclosed in 2d or has no location, or the height is too small.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |