Spatial |
This indicates whether the input spatial element is a valid one.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- spatialElement SpatialElement
- The spatial element to be checked if its geometry can be calculated.
Return Value
BooleanIt will return false if the room/space is not enclosed in 2d or has no location, or the height is too small.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |