The sketch plane assigned to the view for model curve creation.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
The sketch plane, or a null reference (Nothing in Visual Basic) for views which don't allow sketching (such as schedules) or for views that allow model curve creation but have no current sketch plane assigned.Remarks
If this property is set in when the current work plane is visible, the updated work plane will not be shown until the current transaction is committed. Therefore it is recommended the Add-On commits the transaction before performing UI operations (for example, PickPoint).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when setting the property to a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | Thrown when setting the property to a sketch plane that cannot be used to create model elements, or when the input sketch plane is orthogonal to the view orientation. |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when setting the property to a view that does not permit model curve creation, or when other errors occur. |