SketchPlane Property


View Sketch Plane Property

The sketch plane assigned to the view for model curve creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public SketchPlane SketchPlane { get; set; }

Property Value

SketchPlane
The sketch plane, or for views which don't allow sketching (such as schedules) or for views that allow model curve creation but have no current sketch plane assigned.
Exceptions
Exception Condition
ArgumentNullException Thrown when setting the property to .
ArgumentException Thrown when setting the property to a sketch plane that cannot be used to create model elements, or when the input sketch plane is orthogonal to the view orientation.
InvalidOperationException Thrown when setting the property to a view that does not permit model curve creation, or when other errors occur.
Remarks
If this property is set in when the current work plane is visible, the updated work plane will not be shown until the current transaction is committed. Therefore it is recommended the Add-On commits the transaction before performing UI operations (for example, PickPoint).
See Also