HasAssociation Method


Verifies if the element has already defined an association.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public bool HasAssociation(
	ElementId id
)
Visual Basic
Public Function HasAssociation ( _
	id As ElementId _
) As Boolean
Visual C++
public:
bool HasAssociation(
	ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DBElementId
Id of the element to check.

Return Value

Returns true if an association has been found, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also