Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- filename
- Type: SystemString
The fully qualified filename of the Family file, usually ending in .rfa.
- name
- Type: SystemString
The name of the type/symbol to be loaded, such as "W11x14".
- familyLoadOptions
- Type: Autodesk.Revit.DBIFamilyLoadOptions
The interface implementation to use when loading a family into the document.
- symbol
- Type: Autodesk.Revit.DBFamilySymbol%
A reference to the family symbol that was loaded if successful, otherwise Nothing.
Return Value
True if the family type/symbol was loaded successfully into the project, otherwise False.Remarks
This function supports loading of types/symbols stored in the family, or those available in the family Type Catalog file.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Thrown when filename or name is a null reference (Nothing in Visual Basic) or empty. |