Document Load |
Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public bool LoadFamilySymbol(
string filename,
string name,
IFamilyLoadOptions familyLoadOptions,
out FamilySymbol symbol
)
Parameters
- filename String
- The fully qualified filename of the Family file, usually ending in .rfa.
- name String
- The name of the type/symbol to be loaded, such as "W11x14".
- familyLoadOptions IFamilyLoadOptions
- The interface implementation to use when loading a family into the document.
- symbol FamilySymbol
- A reference to the family symbol that was loaded if successful, otherwise Nothing.
Return Value
BooleanTrue if the family type/symbol was loaded successfully into the project, otherwise False.

Exception | Condition |
---|---|
ArgumentException | Thrown when filename or name is or empty. |

This function supports loading of types/symbols stored in the family, or those available in the family Type Catalog file.