Maps a portion of the buffer into memory, so that vertex data can be written into it. (see VertexStream).
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- sizeInFloats
- Type: SystemInt32
The size of the part of the buffer to be mapped, measured in floats. Must be less than or equal to the size of the VertexBuffer
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsInvalidOperationException | This VertexBuffer is not available because Revit is not currently rendering. In general, this VertexBuffer must be used in the scope of the RenderScene() callback of IDirectContext3DServer. -or- Thrown if the buffer is smaller than sizeInFloats. |