Vertex |
Maps a portion of the buffer into memory, so that vertex data can be written into it. (see VertexStream ).
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- sizeInFloats Int32
- The size of the part of the buffer to be mapped, measured in floats. Must be less than or equal to the size of the VertexBuffer

Exception | Condition |
---|---|
InvalidOperationException | This VertexBuffer is not available because Revit is not currently rendering. In general, this VertexBuffer must be used in the scope of the RenderScene() callback of IDirectContext3DServer. -or- Thrown if the buffer is smaller than sizeInFloats. |