Creates the first MultiReferenceAnnotationType element and adds it to the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document to be modified.
Return Value
The new MultiReferenceAnnotationType element.Remarks
If there is no existing MultiReferenceAnnotationType a new one will be created, otherwise an exception will be thrown. Use Duplicate(String) to create all further MultiReferenceAnnotationTypes. The default MultiReferenceAnnotationType will use the document's current default linear dimension style and will have Structural Rebar as its reference category. No tag type will be set for the new MultiReferenceAnnotationType.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | document is not a project document. -or- There are existing MultiReferenceAnnotationTypes in the document. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |