Multi |
Creates the first MultiReferenceAnnotationType element and adds it to the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- document Document
- The document to be modified.
Return Value
MultiReferenceAnnotationTypeThe new MultiReferenceAnnotationType element.

Exception | Condition |
---|---|
ArgumentException | document is not a project document. -or- There are existing MultiReferenceAnnotationTypes in the document. |
ArgumentNullException | A non-optional argument was null |

If there is no existing MultiReferenceAnnotationType a new one will be created, otherwise an exception will be thrown. Use Duplicate(String) to create all further MultiReferenceAnnotationTypes. The default MultiReferenceAnnotationType will use the document's current default linear dimension style and will have Structural Rebar as its reference category. No tag type will be set for the new MultiReferenceAnnotationType.