Gets constrain type of an Adaptive Shape Handle Point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DBDocument
The Document
- refPointId
- Type: Autodesk.Revit.DBElementId
The ReferencePoint id
Return Value
Constraint type of the Adaptive Shape Handle Point.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to a Shape Handle Point. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |