GetPointConstraintType Method


Adaptive Component Family Utils Get Point Constraint Type Method

Gets constrain type of an Adaptive Shape Handle Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static AdaptivePointConstraintType GetPointConstraintType(
	Document doc,
	ElementId refPointId
)

Parameters

doc Document
The Document
refPointId ElementId
The ReferencePoint id

Return Value

AdaptivePointConstraintType
Constraint type of the Adaptive Shape Handle Point.
Exceptions
Exception Condition
ArgumentException The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to a Shape Handle Point.
ArgumentNullException A non-optional argument was null
See Also