Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- edgeReference
- Type: Autodesk.Revit.DBReference
The edge reference.
- faceReference
- Type: Autodesk.Revit.DBReference
The face reference.
- orientWithEdge
- Type: SystemBoolean
Return Value
A new PointOnEdgeFaceIntersection object.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when the input argument edgeReference or faceReference is a null reference (Nothing in Visual Basic). |