Application New |
Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public PointOnEdgeFaceIntersection NewPointOnEdgeFaceIntersection(
Reference edgeReference,
Reference faceReference,
bool orientWithEdge
)
Parameters
- edgeReference Reference
- The edge reference.
- faceReference Reference
- The face reference.
- orientWithEdge Boolean
Return Value
PointOnEdgeFaceIntersectionA new PointOnEdgeFaceIntersection object.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument edgeReference or faceReference is . |