IsValidShape Method (ExternallyTaggedGeometryObject)


Validates shape to be stored in a DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool IsValidShape(
	ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Visual Basic
Public Function IsValidShape ( _
	externallyTaggedGeometry As ExternallyTaggedGeometryObject _
) As Boolean
Visual C++
public:
bool IsValidShape(
	ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)

Parameters

externallyTaggedGeometry
Type: Autodesk.Revit.DB ExternallyTaggedGeometryObject
The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.

Return Value

True if the supplied shape passes the validation criteria.

Remarks

This function uses the same criteria as IsValidShape(GeometryObject).

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also