Direct |
Validates shape to be stored in a DirectShapeType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- externallyTaggedGeometry ExternallyTaggedGeometryObject
- The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.
Return Value
BooleanTrue if the supplied shape passes the validation criteria.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

This function uses the same criteria as IsValidShape(GeometryObject).