SaveAs Method


Save the current view sheet set to another view sheet set with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool SaveAs(
	string newName
)
Visual Basic
Public Function SaveAs ( _
	newName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
	String^ newName
)

Parameters

newName
Type: SystemString
View sheet set name to be saved as.

Return Value

False if Save As operation fails, otherwise True.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the input name is already existed in current view sheet set list.

See Also