AppendItemFromRebarShape Method


Appends an Item to the RebarContainer. Fills its data on base of the Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public RebarContainerItem AppendItemFromRebarShape(
	RebarShape rebarShape,
	RebarBarType barType,
	XYZ origin,
	XYZ xVector,
	XYZ yVector
)
Visual Basic
Public Function AppendItemFromRebarShape ( _
	rebarShape As RebarShape, _
	barType As RebarBarType, _
	origin As XYZ, _
	xVector As XYZ, _
	yVector As XYZ _
) As RebarContainerItem
Visual C++
public:
RebarContainerItem^ AppendItemFromRebarShape(
	RebarShape^ rebarShape, 
	RebarBarType^ barType, 
	XYZ^ origin, 
	XYZ^ xVector, 
	XYZ^ yVector
)

Parameters

rebarShape
Type: Autodesk.Revit.DB.StructureRebarShape
A RebarShape element that defines the shape of the rebar.
barType
Type: Autodesk.Revit.DB.StructureRebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
origin
Type: Autodesk.Revit.DBXYZ
The lower-left corner of the shape's bounding box will be placed at this point in the project.
xVector
Type: Autodesk.Revit.DBXYZ
The x-axis in the shape definition will be mapped to this direction in the project.
yVector
Type: Autodesk.Revit.DBXYZ
The y-axis in the shape definition will be mapped to this direction in the project.

Return Value

The Rebar Container Item.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The rebarShape has End Treatments
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException xVector has zero length. -or- yVector has zero length.

See Also