AppendItemFromRebarShape Method


Rebar Container Append Item From Rebar Shape Method

Appends an Item to the RebarContainer. Fills its data on base of the Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public RebarContainerItem AppendItemFromRebarShape(
	RebarShape rebarShape,
	RebarBarType barType,
	XYZ origin,
	XYZ xVector,
	XYZ yVector
)

Parameters

rebarShape RebarShape
A RebarShape element that defines the shape of the rebar.
barType RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
origin XYZ
The lower-left corner of the shape's bounding box will be placed at this point in the project.
xVector XYZ
The x-axis in the shape definition will be mapped to this direction in the project.
yVector XYZ
The y-axis in the shape definition will be mapped to this direction in the project.

Return Value

RebarContainerItem
The Rebar Container Item.
Exceptions
Exception Condition
ArgumentException A RebarContainerItem cannot be created from a Rebar Shape that has End Treatments or Cranks or terminations' rotation angles are different than 0.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException xVector has zero length. -or- yVector has zero length.
See Also