Merges two adjacent segments into one.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- movedSegmentIndex
- Type: SystemInt32
The index of the moved segment.
- targetSegmentIndex
- Type: SystemInt32
The index of the target segment.
Remarks
Only adjacent segments can be merged. The moved segment will be deleted with all its instances on sheet and all the data will be merged into the target segment with height expanded.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Only two adjacent segments can be merged. -or- The segment index should start from 0 and be less than the total segment count. |