MergeSegments Method


View Schedule Merge Segments Method

Merges two adjacent segments into one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void MergeSegments(
	int movedSegmentIndex,
	int targetSegmentIndex
)

Parameters

movedSegmentIndex Int32
The index of the moved segment.
targetSegmentIndex Int32
The index of the target segment.
Exceptions
Exception Condition
ArgumentException Only two adjacent segments can be merged. -or- The segment index should start from 0 and be less than the total segment count.
Remarks
Only adjacent segments can be merged. The moved segment will be deleted with all its instances on sheet and all the data will be merged into the target segment with height expanded.
See Also