Rotate a profile of the form, by a specified angle around a given axis.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- profileIndex
- Type: SystemInt32
Index to specify the profile.
- axis
- Type: Autodesk.Revit.DBLine
An unbounded line that represents the axis of rotation.
- angle
- Type: SystemDouble
The angle, in radians, by which the element is to be rotated around the specified axis.