Form Rotate Profile Method Rotate a profile of the form, by a specified angle around a given axis. Namespace: Autodesk.Revit.DB Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0) Syntax C# VB C++ F# public void RotateProfile( int profileIndex, Line axis, double angle ) Public Sub RotateProfile ( profileIndex As Integer, axis As Line, angle As Double ) public: void RotateProfile( int profileIndex, Line^ axis, double angle ) member RotateProfile : profileIndex : int * axis : Line * angle : float -> unit Parameters profileIndex Int32 Index to specify the profile. axis Line An unbounded line that represents the axis of rotation. angle Double The angle, in radians, by which the element is to be rotated around the specified axis. See Also Reference Form Class Autodesk.Revit.DB Namespace
Form Rotate Profile Method Rotate a profile of the form, by a specified angle around a given axis. Namespace: Autodesk.Revit.DB Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0) Syntax C# VB C++ F# public void RotateProfile( int profileIndex, Line axis, double angle ) Public Sub RotateProfile ( profileIndex As Integer, axis As Line, angle As Double ) public: void RotateProfile( int profileIndex, Line^ axis, double angle ) member RotateProfile : profileIndex : int * axis : Line * angle : float -> unit Parameters profileIndex Int32 Index to specify the profile. axis Line An unbounded line that represents the axis of rotation. angle Double The angle, in radians, by which the element is to be rotated around the specified axis. See Also Reference Form Class Autodesk.Revit.DB Namespace