DimensionStyleType Property


The dimension style type to be used by the new MultiReferenceAnnotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public DimensionStyleType DimensionStyleType { get; set; }
Visual Basic
Public Property DimensionStyleType As DimensionStyleType
	Get
	Set
Visual C++
public:
property DimensionStyleType DimensionStyleType {
	DimensionStyleType get ();
	void set (DimensionStyleType value);
}

Remarks

Only Linear and LinearFixed types are allowed.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: dimensionStyleType must be either Linear or LinearFixed to be used by MultiReferenceAnnotations.
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also