DimensionStyleType Property


Multi Reference Annotation Options Dimension Style Type Property

The dimension style type to be used by the new MultiReferenceAnnotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public DimensionStyleType DimensionStyleType { get; set; }

Property Value

DimensionStyleType
Exceptions
Exception Condition
ArgumentException When setting this property: dimensionStyleType must be either Linear or LinearFixed to be used by MultiReferenceAnnotations.
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
Only Linear and LinearFixed types are allowed.
See Also