SetStringValue Method


Sets new String value of entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public void SetStringValue(
	string value
)
Visual Basic
Public Sub SetStringValue ( _
	value As String _
)
Visual C++
public:
void SetStringValue(
	String^ value
)

Parameters

value
Type: SystemString

Remarks

This method should only be used if the StorageType property reports the type of the entry as a String. New value should be not empty and valid for Revit name.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The entry has different storage type with String, or the value is empty, or contains forbidden characters.

See Also