SetStringValue Method


Color Fill Scheme Entry Set String Value Method

Sets new String value of entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetStringValue(
	string value
)

Parameters

value String
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException The entry has different storage type with String, or the value is empty, or contains forbidden characters.
Remarks
This method should only be used if the StorageType property reports the type of the entry as a String. New value should be not empty and valid for Revit name.
See Also