Indicates that the caller has finished defining the given face.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- faceId
- Type: Autodesk.Revit.DBBRepBuilderGeometryId
Id of the face.
Remarks
No functions that modify the given face's definition should be called after calling this function (e.g., AddLoop(BRepBuilderGeometryId), SetFaceMaterialId(BRepBuilderGeometryId, ElementId)). The BRepBuilder may take the opportunity to validate some of the face's data and report any problems it finds.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The supplied face id doesn't correspond to a face stored in this BRepBuilder object. -or- FinishFace() has already been called on faceId. -or- The face has no edge loops. -or- FinishLoop() must be called on all the edge loops of faceId. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |