FinishFace Method


BRep Builder Finish Face Method

Indicates that the caller has finished defining the given face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void FinishFace(
	BRepBuilderGeometryId faceId
)

Parameters

faceId BRepBuilderGeometryId
Id of the face.
Exceptions
Exception Condition
ArgumentException The supplied face id doesn't correspond to a face stored in this BRepBuilder object. -or- FinishFace() has already been called on faceId. -or- The face has no edge loops. -or- FinishLoop() must be called on all the edge loops of faceId.
ArgumentNullException A non-optional argument was null
Remarks
No functions that modify the given face's definition should be called after calling this function (e.g., AddLoop(BRepBuilderGeometryId) , SetFaceMaterialId(BRepBuilderGeometryId, ElementId) ). The BRepBuilder may take the opportunity to validate some of the face's data and report any problems it finds.
See Also